Форумы » Операционные системы » Raspbian

Нет директории или файл не найден.

opranda


Сообщений: 2

отправлено 11 Октябрь 2017 в 21:08

Люди, что может быть?

При вводе любой команды, пишет либо нет директории или файл не найден.

Вот, что я устанавливал и что из этого вышло. Ссылка

И так:

sudo apt-get update ( на малинке обновляет )

Далее запускаю: sudo apt-get install weavedconnectd

pi@raspberrypi:~$ sudo apt-get install weavedconnectd
Reading package lists... Done
Building dependency tree
Reading state information... Done
weavedconnectd is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 137 not upgraded.
pi@raspberrypi:~$

Запускаю: sudo weaveinstaller

pi@raspberrypi:~$ sudo weaveinstaller
sudo: weaveinstaller: command not found
pi@raspberrypi:~$

Вопрос. Что не так?

Или например, пытаюсь установить  VNC сервер на Raspberry Pi 

Запускаю: sudo apt-get install tightvncserver

pi@raspberrypi:~$ sudo apt-get install tightvncserver
Reading package lists... Done
Building dependency tree
Reading state information... Done
tightvncserver is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 137 not upgraded.
pi@raspberrypi:~$

Далее: tightvncserver

pi@raspberrypi:~$ tightvncserver
-bash: /usr/bin/tightvncserver: /usr/bin/perl: bad interpreter: No such file or directory

Пробую через: sudo

pi@raspberrypi:~$ sudo tightvncserver
sudo: unable to execute /usr/bin/tightvncserver: No such file or directory


Куда копать? подскажите пожалуйста.


chug17


Сообщений: 13

отправлено 11 Октябрь 2017 в 21:15

tightvncserver is already the newest version. это говорит о том, что tightvncserver уже был установлен ранее.

 /usr/bin/perl: bad interpreter: No such file or directory - надо установить perl
sudo apt-get install perl

opranda


Сообщений: 2

отправлено 11 Октябрь 2017 в 21:18

Вот что происходит

pi@raspberrypi:~$ sudo apt-get install perl
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  perl-base perl-modules
Suggested packages:
  perl-doc libterm-readline-gnu-perl libterm-readline-perl-perl libb-lint-perl
  libcpanplus-dist-build-perl libcpanplus-perl libfile-checktree-perl
  libobject-accessor-perl
The following packages will be upgraded:
  perl perl-base perl-modules
3 upgraded, 0 newly installed, 0 to remove and 134 not upgraded.
Need to get 0 B/5,708 kB of archives.
After this operation, 5,120 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Reading changelogs... Done
/bin/sh: 1: /usr/sbin/dpkg-preconfigure: not found
Could not exec dpkg!
E: Sub-process /usr/bin/dpkg returned an error code (100)
pi@raspberrypi:~$

Для того, чтобы написать сообщение в тему, необходимо авторизоваться!