Форумы » Эксплуатация » Базовая настройка и использование

Проблема раскладки клавиатуры в Raspbian

Nevzor


Сообщений: 0

отправлено 07 Январь 2017 в 17:57

Сразу скажу, гуглил и читал форум, однако не один из найденных способов не помог. Ситуация такая, после установки Raspbian на свою «Raspberry Pi 3» столкнулся с проблемой, после каждой перезагрузки слетает английская раскладка и клавиши переключения раскладок. То есть, так как в системе выбрана русская локаль, после каждой перезагрузки единственная доступная раскладка клавиатуры это русская. Даже если настроить всё самому, добавить американский английский, указать клавиши переключения раскладок, после перезагрузки всё опять слетает. Пробовал редактировать через «sudo raspi-config», создал в домашней папке файл ".xsessionrc", бесполезно! Не скажу, что это прям жёсткий косяк, но очень раздражающий… Буду рад если опытные комрады дадут мне добрый совет :)

AlexYeCu


Сообщений: 0

отправлено 02 Февраль 2017 в 00:40

А если задействовать апплет панельки из LXDE (Pixel), вместе с галочкой «игнорирповать системные настройки» — тоже слетает?

Bor


Сообщений: 4

отправлено 16 Август 2017 в 00:45

javascript:nicTemp(); есть решение этой проблемы.

Bor


Сообщений: 4

отправлено 16 Август 2017 в 01:00

Также рекомендуется внести изменения в /etc/default/keyboard

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="us,ru"
XKBVARIANT=","
XKBOPTIONS="grp:alt_shift_toggle,grp_led:scroll"

BACKSPACE="guess"

Или использовать для настройки raspi-config

Bor


Сообщений: 4

отправлено 20 Август 2017 в 19:29

Нашел решение проблемы с раскладкой клавиатуры. Муторно, ручками, но работает. 
Открываем Файловый менеджер и жмем Ctrl+H чтобы увидеть скрытые файлы.
По умолчанию он откроется в папке /home/pi.
Идем в папку .config -> lxpanel -> LXDE-pi -> panels и открываем файл panel
Ищем в самом конце разделPlugin {
type=xkb
Config {
Model=pc105
LayoutsList=gb
VariantsList=,
ToggleOpt=grp:shift_caps_toggle
}
}И в разделе LayoutsList стираем gb и пишем us,ru
В разделе ToggleOpt заменяем значение на то которое вы переписали с кнопки.
В следующей строке добавляем параметр KeepSysLayouts=0
Получится что-то такоеPlugin {
type=xkb
Config {
Model=pc105
LayoutsList=us,ru
VariantsList=,
ToggleOpt=grp:alt_shift_toggle
KeepSysLayouts=0
}
}Жмем Файл -> Сохранить
И перезагружаемся.
Готово, переключатель работает
Правда если захотите что-то изменить, все придется опять править вручную, потому что из графического интерфейса настройки не сохраняются.Это по инструкции одного умного товарища. От себя добавлю следующие изменения.Plugin {  type=xkb  Config {    Model=pc105    LayoutsList=us,ru    VariantsList=,    ToggleOpt=grp:alt_shift_toggle,grp_led:scroll    KeepSysLayouts=0    TextSize=1    DisplayType=1    NoResetOpt=1  }}При таком редактировании вместо флага будет обозначение раскладки (RU,US) и при русской раскладке загорится светодиод scroll lock

Bor


Сообщений: 4

отправлено 20 Август 2017 в 19:39

что то в сообщении все в кучу свалилось не могу найти где тут редактирование. Еще хотел сказать что для того что бы открыть нужный файл для редактирования можно просто набрать 
sudo leafpad /home/pi/.config/lxpanel/LXDE-pi/panels/panel
и далее по инструкции выше.

djbond07


Сообщений: 15

отправлено 24 Август 2017 в 13:58

Всё очень просто делается через raspi-config. После настройки локалей нужно выбрать пункт Change keyboard layout, и там пошагово всё настроить, вплоть до того, какими кнопками будет переключаться раскладка. 
Пробовали так делать?

Master


Сообщений: 2

отправлено 20 Август 2018 в 01:30

Приобрел Raspberry Pi 3 B+. Проблема описанная выше до сих пор сохраняется. 
Обе настройки описанные выше работают, но если настраивать через raspi-config, то на панели отображается американский флаг при английской раскладке и ничего при русской, и переключение можно делать только на клавиатуре. Если настраивать так описано у Bora, то флажочки меняются соответственно и язык ввода так же можно выбирать кликая мышью по флагу.

Master


Сообщений: 2

отправлено 22 Август 2018 в 23:04

Нашел самый простой способ обхода проблемы без танцев с бубнами. 

Добавляем на панель значок раскладки клавиатуры, заходим в настройки раскладки, добавляем нужные языки, изменяем по желанию другие настройки. Далее как известно окно не закрывается кнопкой "Закрыть". Ну, ничего страшного, хотите закрывайте его крестиком, хотите оставляйте его открытым. 

Далее кликаем правой клавишей мыши в районе значков на панели, выбираем в меню настройки панели (Panel Settings), в открышевся окне меняем любой из параметров, нажимаем "Закрыть".

Перезагружаем Малинку. И, вуаля, значок языков отзывается на изменения раскладки языков, флажочки меняются и клавиатурой тоже переключаются. ))))

Для того, чтобы написать сообщение в тему, необходимо авторизоваться!