Форумы » Операционные системы » Raspbian

Не работает wi-fi

ivakirt


Сообщений: 0

отправлено 06 Январь 2017 в 00:19

Получил pi3, стоит raspbian 4.9.2-10 (скачана с офф сайта, ставил как через noobs, так и заливкой на флешку готового образа.), Linux 4.4.34-v7+(armv7l). На чистую систему установлен только NoMachine. Не получается подключиться к wi-fi — сети находит, ключ спрашивает, когда ввожу — никакой реакции, не подключается. Снял пароль с сети, поменял регион на ru, каналы на маршрутизаторе (tp-link 1043nd, openwrt) — всё нипочем. Пытался подключиться к точке доступа своего смартфона (Meizu m2 note), результат то же. По lan сеть есть, но нужен wi-fi. ifconfig показывает, что не идут Tx-пакеты.

Содержимое файлов:

/etc/network/interfaces

source-directory /etc/network/interfaces.d



auto lo

iface lo inet loopback



iface eth0 inet dhcp



allow-hotplug wlan0

iface wlan0 inet dhcp

wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

iface default inet dhcp

/etc/wpa_supplicant/wpa_supplicant.conf

trl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

update_config=1

country=RU



network={

ssid=«Op»

key_mgmt=NONE

}

Anton7


Сообщений: 11

отправлено 06 Январь 2017 в 10:19

Я правильно понимаю: роутер не раздает wi-fi? Тогда причем здесь малинка? Разберитесь с роутером. Обновите прошивку, скачайте мануал. Как достучитесь с телефона — занимайтесь малинкой.

ivakirt


Сообщений: 0

отправлено 06 Январь 2017 в 11:39

Наверно я неправильно выразился. Роутер раздает wi-fi, другие устройства подключаются, получают ip, в общем работает он. А малина видит его, спрашивает пароль, но не подключается. Так же с точкой доступа телефона — видит, но не подключается.

akioalx


Сообщений: 0

отправлено 21 Февраль 2017 в 18:52

ivakirt (2017-01-06 00:19:56):
Получил pi3, стоит raspbian 4.9.2-10 (скачана с офф сайта, ставил как через noobs, так и заливкой на флешку готового образа.), Linux 4.4.34-v7+(armv7l). На чистую систему установлен только NoMachine. Не получается подключиться к wi-fi — сети находит, ключ спрашивает, когда ввожу — никакой реакции, не подключается. Снял пароль с сети, поменял регион на ru, каналы на маршрутизаторе (tp-link 1043nd, openwrt) — всё нипочем. Пытался подключиться к точке доступа своего смартфона (Meizu m2 note), результат то же. По lan сеть есть, но нужен wi-fi. ifconfig показывает, что не идут Tx-пакеты.

Содержимое файлов:

/etc/network/interfaces

source-directory /etc/network/interfaces.d



auto lo

iface lo inet loopback



iface eth0 inet dhcp



allow-hotplug wlan0

iface wlan0 inet dhcp

wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

iface default inet dhcp

/etc/wpa_supplicant/wpa_supplicant.conf

trl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

update_config=1

country=RU



network={

ssid=«Op»

key_mgmt=NONE

}
 
конфиг поправте



это в интерфейсах — все что касается wlan0:



allow-hotplug wlan0

iface wlan0 inet dhcp

wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf




это файл wpa:

country=RU

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

update_config=1

network={

ssid=«SSID моей точки доступа»

scan_ssid=1

psk=«мой_password»

}




http://home-smart-home.ru/raspberry-pi-nastrojka-seti/

Для того, чтобы написать сообщение в тему, необходимо авторизоваться!