Не работает wi-fi

Сообщение #1
06 января 2017, 00:19 | Не работает wi-fi
Получил pi3, стоит raspbian 4.9.2-10 (скачана с офф сайта, ставил как через noobs, так и заливкой на флешку готового образа.), Linux 4.4.34-v7+(armv7l). На чистую систему установлен только NoMachine. Не получается подключиться к wi-fi — сети находит, ключ спрашивает, когда ввожу — никакой реакции, не подключается. Снял пароль с сети, поменял регион на ru, каналы на маршрутизаторе (tp-link 1043nd, openwrt) — всё нипочем. Пытался подключиться к точке доступа своего смартфона (Meizu m2 note), результат то же. По lan сеть есть, но нужен wi-fi. ifconfig показывает, что не идут Tx-пакеты.
Содержимое файлов:
/etc/network/interfaces
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp
/etc/wpa_supplicant/wpa_supplicant.conf
trl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=RU

network={
ssid=«Op»
key_mgmt=NONE
}
Последний раз редактировал пользователь ivakirt - 06 января 2017, 00:20
Сообщений в теме: 3

Ответы в тему

Сообщение #2
06 января 2017, 10:19
Я правильно понимаю: роутер не раздает wi-fi? Тогда причем здесь малинка? Разберитесь с роутером. Обновите прошивку, скачайте мануал. Как достучитесь с телефона — занимайтесь малинкой.
Сообщение #3
06 января 2017, 11:39
Наверно я неправильно выразился. Роутер раздает wi-fi, другие устройства подключаются, получают ip, в общем работает он. А малина видит его, спрашивает пароль, но не подключается. Так же с точкой доступа телефона — видит, но не подключается.